Mounting data DVDs?

Ronald F. Guilmette rfg at
Thu Feb 16 12:38:51 PST 2006

I know that I'm very late to the party, but I just recently bought and
installed my first ever DVD burner.

The burner is installed on a system that I have set up to dual boot
to either FreeBSD 5.2.1 (yea, I know, that's ancient) or else to
Windoze ME.

So anyway, yesterday I followed all of the instructions located at:

in order to create and install a fresh kernel that would have all of the
required stuff in it to be able to burn data DVDs.

I then burned my first ever data DVD... made from some data I had that I
wanted to make a backup of.

All went smoothly.  So far, so good.

The tricky part came when I then went to _mount_ my freshly burned DVD
onto FreeBSD.  (I wanted to do this just in order to verify that the
data had in fact successfully been burned onto the DVD.)

Unfortunately, try as I might, I couldn't fingure out how to just simply
mount the burned DVD onto the FreeBSD system.  I tried both:

    mount -t cd9660 /dev/cd0 /mnt

which yielded only the error message:

    cd9660: /dev/cd0: Device not configured

and I also tried:

    mount -t cd9660 /dev/acd0 /mnt

which yielded the error:

    cd9660: /dev/acd0: Input/output error

OK, so what am I doing wrong?

Note that I have attached the relevant portion of my dmesg output at the
end of this message... just in case that might be useful in diagnosing
this problem.

The REALLY funny thing about all this is that I am 100% sure that the DVD
in question *did* get properly burned, because I can reboot this same
system into Windows ME, and then, Windows ME has no trouble at all seeing
either the DVD or all of the files that I burned onto it.

So basically, I can _burn_ a DVD under FreeBSD... I just can't figure out
how to use it on FreeBSD, once it has been successfully burned.

Sound I just ungrade to something a bit fresher than 5.2.1, or does that
make any difference at all?

Any help appreciated.

dmesg stuff:
ata1-master: DMA limited to UDMA33, non-ATA66 cable or device
acd0: DVDR <LITE-ON DVDRW SOHW-1673S> at ata1-master UDMA33
GEOM: create disk cd0 dp=0xc2d81e00
cd0 at ata1 bus 0 target 0 lun 0
cd0: <LITE-ON DVDRW SOHW-1673S JS05> Removable CD-ROM SCSI-0 device 
cd0: 33.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present

More information about the freebsd-questions mailing list