core dump with dump command SOLVED

Giorgos Keramidas keramida at
Thu Feb 16 07:06:26 PST 2006

On 2006-02-16 09:56, Joe Auty <joe at> wrote:
>On Feb 16, 2006, at 9:52 AM, Giorgos Keramidas wrote:
>>On 2006-02-16 09:29, Joe Auty <joe at> wrote:
>>> Thanks everybody for their help.
>>> As it turns out, I guess dump was being starved for memory,
>>> as running it while booted into FreeBSD normally using -L to
>>> indicate a live filesystem worked just fine. I believe this
>>> is because there is an extra swap file available from a
>>> normal FreeBSD boot, as specified in my /etc/rc.conf. I'm not
>>> sure if my theory completely holds up, but there you have it.
>>> Thanks again! I'm up and running...
>> That's very likely.  I usually start single user mode with
>> something like the following:
>>     # adjkerntz -i
>>     # swapon -a
>>     # fsck -p
>>     # mount -u /
>>     # mount -va
>> Having a swap partition enabled definitely helps to avoid
>> ending up without any free memory ;)
> I was doing swapon -a too, but perhaps this command does not enable
> swap directories that have been attached to /etc/rc.conf?

It enables all partitions listed as 'swap' in /etc/fstab.  You
are probably using a `swapfile', instead of a swap partition, so
that wouldn't enable it, because the relevant file system may not
be mounted at the time you run 'swapon'.

This is one of the reasons behind my tendency to use a separate
swap partition instead of swapfile="foo" in `/etc/rc.conf' :-/

More information about the freebsd-questions mailing list