lprps: ioctl(TIOCFLUSH): Operation not permitted

Bjarne Wichmann Petersen freebsd.nospam at mekanix.dk
Mon Feb 13 01:18:33 PST 2006


I did something stuppid and messed up my lpd-setup. I looked around in KDE's 
"Printer Manager" in administrator-mode, and even though I didn't apply any 
changes it activated cupsd (should it do that?) which in turn overwrote 
my /etc/printcap. Now I can't get back to the old and working setup.

I've removed /usr/local/etc/rc.d/cups.sh, so /etc/printcap doesn't get 
overwritten any more.

Though I don't have a copy of my /etc/printcap I found older copy (which might 
be identical) which have worked in the past:

laserjet|lp|ps|PS|S|hp|HP LaserJet 1200:\

The psif-filter is installed and at that location.

lpd is up and running.

Now, if I try to print anything I get this errormessage in console/syslog:

eb 13 09:50:46 desktop lprps[842]: laserjet: ioctl(TIOCFLUSH): Operation not 
supported by device
Feb 13 09:50:46 desktop lpd[836]: laserjet: job could not be printed 

I've tried to fiddle around with lptcontrol and gets tiocflush-errors for all 
switches but -s.

I have NO idea for where to look next. Google doesn't turn up anything useful 
on tiocflush and I have no idea what it means.


More information about the freebsd-questions mailing list