recovering from failed cvsup upgrade

wo_shi_big_stomach wo_shi_big_stomach at
Thu Feb 9 07:29:02 PST 2006

Greetings. I need help recovering a system that became
unresponsive during an upgrade. Steps:

1. Using cvsup, I tried to upgrade a system from
RELENG_5_2 to RELENG_5_3 with the usual sequence:

cvsup -g -L 2 (cvsup file)
make -j 4 buildworld
make buildkernel KERNCONF=SMP
make installkernel KERNCONF=SMP
mergemaster -p
make installworld

This last step complained about the lack of some
attributes needed for pf. 

After several attempts to repeat the whole cycle, I
gave up and tried to roll back to RELENG_5_2. To do
this, I repeated all steps above starting with a cvsup
for the RELENG_5_2 branch.

I did all this via ssh and the system became
unreponsive (on all ports, not just ssh) during the
downgrade. The machine is at a different location but
I will go there in a couple of hours.

Thanks in advance for any clues as to how I can
recover this system. 

If it matters, the system is a Compaq Proliant 1850R
with dual 550-MHz Pentium III CPUs and 512 Mbytes RAM.

More information about the freebsd-questions mailing list