Support for ACLs missing in dump&restore?

Jan Srzednicki w at
Tue Feb 7 12:41:23 PST 2006


I've just migrated to 6.0 (-STABLE as of January the 31th) and started
playing with ACLs on it.  Everything went fine until I tried to
dump&restore the partition I've been using ACLs on. Well, to make things
short, it appears that neither dump nor restore understands or has any
idea of existence of extended UFS2 attributes, and in particular of
ACLs. A quick look at the source tree:

cd /usr/src/sbin && grep -riE '(extattr|acl)' dump restore

(that should show usage of extattr_*(2) family of functions, or
acl_*(3), or __acl_*(2), if I'm getting this right)

Shows that I'm right and there's indeed no support for it. I've also
checked CVS logs for src/sbin/dump/main.c (and some other files there)
and the only relevant info is that dump has been modified to understand
UFS2, but extattr is still missing.

I tried googling and found an article on ONLamp, which says that
FreeBSD's dump and restore utilities have been modified to understand

Well, if it so, how can I make dump and restore to restore my ACLs
right? If not, what is the recommended way of getting a filesystem with
ACLs backuped? The handbook doesn't mention that dump and restore are
missing ACL support:

Man pages don't mention anything about ACLs or extaddr, no flag to
enable them or anything.

Just to make sure, I had both filesystems (the one being dumped and the
one dumped to) tunefs -a enabled and mounted with explicit -oacls. I
have checked them with dumpfs and both show as UFS2 and have "flags acls".

Well then, did someone just forget about it or is there any other better
official way to do backups? pax(1) doesn't seem to support ACLs as well,
although AFAIK it was designed to be able to store and extract them by
the POSIX people.

Jan Srzednicki
w at

More information about the freebsd-questions mailing list