pxe clients with freebsd 6.0-rel ?

Paul Eskello paul.eskello at gmail.com
Fri Feb 3 12:45:21 PST 2006


for some months now I do run pxe clients running 5.4-rel with no
problems, with a 4.10-rel box as dhcp/tftp/nfs server. I just followed
the strategy outlined in the handbook

Now with the upcoming 6.1 release I cvsuppped the pxe-client to
RELENG_6_0, build both kernel and world en installed it. He boots ok,
but now sendmail does not run and also vipw does not run (it stucks
with starting vi). I also observed I'm not able to open an files for
the second time in a row while the first attempt succeeded (not with
vi ofcourse).

I tried to upgrade this pxe-client as well a few months ago in order
to beta-drive RELENG_6 and the situation was the same. I then happened
to compile vim on the box and that ran troublefree. But that was a
quick test lasting an hour or so and without a running vipw.

I doublechecked rpcbind, rpc.lockd en rpc.statd assumed they were not
running. They were.

I then decided to upgrade the pxe server running RELENG_4_10 to
RELENG_5_4 to RELENG_6_0. That went flawless, but the pxe-client still
behaved the same. Also, another pxe-client running RELENG_5_4 now was
showing troubles with locking files as described above.

Doing some research with cvs commits logs and cvsweb.freebsd.org I
learned /usr/src/sys/rpc.lockd/kern.c was changed. I checked out
version 1.13 and tried to recompile: that went wrong. As a second
attempt, I plainly copied /usr/src/sys/usr.sbin/rpc.lockd/* from a
RELENG_5_4 box to the client. That also did not make my compiler happy
and broke before a usefull finish. I did not bother waiting for a make
-k :-)

Last week I tried to create a clean install (with the pxe-server still
running RELENG_6_0 at that time) to make a installworld with
DESTDIR=/var/pxe/client1, and make distribution and so on and pointed
my "option root-path" in dhcpd.conf to that directory. The client did
boot but was still showing the (presumed !) file locking trouble.

Now I was thinking: Is there anyone here who IS running RELENG_6_0 pxe
clients without the file-locking trouble I encounter over the last few
months. Anyone who just can run vipw for three times in a row and
where sendmail is just running. Yes sendmail starts but it does not
display a banner and cannot be killed, netstat shows me it's not bond
to any port.

Can anyone point me to a solution, make a hint about where to look,
what to check or do, or just give me the answer: "cannot be done with
6" :-/

I'm willing to test, patch or do whatever to make the thing work with
6 (time permitting ofcourse).

Thanks for reading.


More information about the freebsd-questions mailing list