Can not power-off or reboot on Acer Aspire 5100 laptop.

Janvier Pang janvier.roc at
Thu Dec 21 10:11:56 PST 2006

Hi everyone,

I have a new Acer Aspire 5100 laptop and a FreeBSD 6.2-RC1 installed. When I
shutdown the machine by "shutdown -p now" command, the machine will hang
after printing the "All Buffers Synced. Uptime: xx:xx" messages.

If I use the "reboot" command to reboot the machine, i got the same result
as the shutdown one.

I've tried to add the following lines into /etc/rc.conf, but it didn't work.


I've tried to use some alternative command instead of "shutdown", but they
didn't work too:

acpiconf -s 5
init 0

I've tried to disable the ACPI function on start up, the system will crash
and reboot.

Could anybody kindly help or give some hints to solve this shutting down


dmesg informations:

Copyright (c) 1992-2006 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.2-RC1 #0: Thu Nov 16 05:01:36 UTC 2006
    root at
ACPI APIC Table: <PTLTD           APIC  >
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Turion(tm) 64 Mobile Technology MK-36 (1995.02-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x40fc2  Stepping = 2
  AMD Features=0xea500800<SYSCALL,NX,MMX+,FFXSR,RDTSCP,LM,3DNow+,3DNow>
  AMD Features2=0x1d<LAHF,<b2>,<b3>,CR8>
real memory  = 535363584 (510 MB)
avail memory = 514461696 (490 MB)
MADT: Forcing active-low polarity and level trigger for SCI
ioapic0 <Version 2.1> irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: <ACRSYS   RSDT> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <32-bit timer at 3.579545MHz> port 0x8008-0x800b on acpi0
acpi_ec0: <Embedded Controller: GPE 0x10> port 0x62,0x66 on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 2.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
pcib2: <ACPI PCI-PCI bridge> at device 4.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 5.0 on pci0
pci4: <ACPI PCI bus> on pcib3
atapci0: <ATI IXP400 SATA150 controller> port
0x8440-0x8447,0x8434-0x8437,0x8438-0x843f,0x8430-0x8433,0x8400-0x840f mem
0xc0004000-0xc00041ff irq 22 at device 18.0 on pci0
ata2: <ATA channel 0> on atapci0
ata3: <ATA channel 1> on atapci0
ohci0: <ATI SB400 USB Controller> mem 0xc0005000-0xc0005fff irq 19 at device
19.0 on pci0
usb0: OHCI version 1.0, legacy support
usb0: <ATI SB400 USB Controller> on ohci0
usb0: USB revision 1.0
uhub0: ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
ohci1: <ATI SB400 USB Controller> mem 0xc0006000-0xc0006fff irq 19 at device
19.1 on pci0
usb1: OHCI version 1.0, legacy support
usb1: <ATI SB400 USB Controller> on ohci1
usb1: USB revision 1.0
uhub1: ATI OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 4 ports with 4 removable, self powered
ehci0: <ATI SB400 USB 2.0 controller> mem 0xc0007000-0xc0007fff irq 19 at
device 19.2 on pci0
usb2: EHCI version 1.0
usb2: companion controllers, 4 ports each: usb0 usb1
usb2: <ATI SB400 USB 2.0 controller> on ehci0
usb2: USB revision 2.0
uhub2: ATI EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub2: 8 ports with 8 removable, self powered
pci0: <serial bus, SMBus> at device 20.0 (no driver attached)
atapci1: <ATI IXP400 UDMA133 controller> port
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x8420-0x842f at device 20.1 on pci0
ata0: <ATA channel 0> on atapci1
ata1: <ATA channel 1> on atapci1
pci0: <multimedia> at device 20.2 (no driver attached)
isab0: <PCI-ISA bridge> at device 20.3 on pci0
isa0: <ISA bus> on isab0
pcib4: <ACPI PCI-PCI bridge> at device 20.4 on pci0
pci6: <ACPI PCI bus> on pcib4
rl0: <RealTek 8139 10/100BaseTX> port 0xa000-0xa0ff mem
0xc0210000-0xc02100ff irq 21 at device 1.0 on pci6
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> on miibus0
rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl0: Ethernet address: 00:16:d4:64:fb:64
ath0: <Atheros 5212> mem 0xc0200000-0xc020ffff irq 22 at device 2.0 on pci6
ath0: Ethernet address: 00:16:cf:9c:38:59
ath0: mac 7.8 phy 4.5 radio 5.6
cbb0: <PCI-CardBus Bridge> mem 0xc0211000-0xc0211fff irq 20 at device 4.0 on
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
pci6: <memory, flash> at device 4.1 (no driver attached)
pci6: <base peripheral> at device 4.2 (no driver attached)
pci6: <memory, flash> at device 4.3 (no driver attached)
pci6: <memory, flash> at device 4.4 (no driver attached)
acpi_tz0: <Thermal Zone> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model Generic PS/2 mouse, device ID 0
battery0: <ACPI Control Method Battery> on acpi0
acpi_acad0: <AC Adapter> on acpi0
pmtimer0 on isa0
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250 or not responding
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 1995015403 Hz quality 800
Timecounters tick every 1.000 msec
acd0: DVDR <PIONEER DVD-RW DVR-K16RS/1.39> at ata0-master UDMA33
ad4: 114473MB <Seagate ST9120821AS 3.06> at ata2-master SATA150
Trying to mount root from ufs:/dev/ad4s4a

More information about the freebsd-questions mailing list