Toshiba Satellite Pro 4300 and FreeBSD 5.5

User Tomdean tomdean at
Sun Aug 27 02:29:53 UTC 2006

I tried installing FreeBSD 5.5 from the subscription CD on a Toshiba
Satellite Pro 4300.

I previously had FreeBSD 4.1 on this machine.

All options in the boot menu hang at the same place (the last two are
N/A in this case).

I tried setting hint.acpi.0.disabled="1" and boot -v -c.  Hangs.  I
tried loading the atapci_toshiba.ko module - same result.

The last messages are:

ata0-master: stat=0x50 err=0x01 lsb=0x00 msb=0x00
ata0-slave: stat=0x00 err=0x01 lsb=0x00 msb=0x00
ata0: reset tp2 stat0=50 stat1=50 devices=0x1<ATA_MASTER>
ata0: [MPSAFE]
ata1: channel 1 on atapci0
atapci0: Reserved 0x8 bytes for rid type 4 at 0x170
atapci0: Reserved 0x1 bytes for rid type 4 at 0x376
<-- hang forever or 10 minutes, whichever is longer.

I remember reading something about the Satellite Pro models, but can't
find it.

Can anyone provide some information/guidance?


More information about the freebsd-questions mailing list