More newbie questions

backyard backyard1454-bsd at
Wed Aug 23 21:07:36 UTC 2006

--- "E. Gad" <p1agu313 at> wrote:

> Svein Halvor Halvorsen <svein.h at>
> wrote: Subhro wrote:
> > yourself. However remember to cvsup your ports
> tree before you start
> > using it to get the required software. Refer to
> the handbook for
> > understanding how ports work.
> For most people portsnap would be a better way of
> updating one's ports
> tree. Firstly, it's in the base system and thus
> doesn't require any
> third party software. Secondly, most newbies find it
> easier to use.

as long as your remember to install it as a port
during the install or add it with sysinstall or
pkg_add. cvsup-nogui then doing a:

make update in /usr/src or /usr/ports will
automagically use the default examples and update
things. As long as your going from a 6.x base it will
continue on Rel_6.x. If you started with 5.x it will
continue to update 5.x. Ports will always update to
the latest and greatest as it uses a different tag. I
find this very easy, I'm also afraid of change. Though
portsnap is more secure because it uses encryption and
I've heard signs the updates. To each their own though
one way of the other updating your SRC and PORTS is an
important thing to learn how to do.

>  Svein Halvor
> Hmm porstnap seemed to have worked ok. I installed
> the portupgrade suite through pkg_add. 
>  Somethings still not happy. Because when  took a
> stab at installing:
>  nvidia-driver
>  nvidia-glx
>  xorg and compat 5 as a dependency for
> nvidia-driver/nvidia-glx
>  nvidia can't find something and I don't know what
> because the first part of the message scrolls of the
> screen- (remember I'm not in xorg yet)

if you don't have X yet then I don't think the nvidia
drivers will install because they are quite dependant
on X.

no X required here...
hit scroll lock and then PgUp and PgDn this will let
you view the scroll back buffer and see what you
cannot see. the up and down arrows will work too.

>  -What the newbie here has done so far to help
> itself-
>  Just as a guess-reinstalled linux_base because I
> remembered reading on a Just Some Guys 'Blog abut
> the same problem
>  thinking it couldn't hurt anything since I hadn't
> installed hardly much of anything-
>  cd /usr/ports/emulators/linux_base.
>  make deinstall
>  make clean
>  make install
>  Ran that for 15 minuts-it ran into some sort of 
>  "error 1!" (repeated 5 times)
>  Undaunted-re- did make etc.
>  Somethng about rpm something not found 
>  (cd'd into linux_bas-fc4)
>  ran make install clean-but it says it can't find
> the  ftp servers-
>  Any guesses what I'm doing wrong?

install archivers/rpm should fix that but it should
know to do it itself. Unless your stuck using that
particular dist of linux I would try to gentoo stage3
base. a chroot to the /compat/linux and you can use
their portage system to install and update linux apps
fairly easy. The reason I got away from linux in the
first place was the nightmare of updating it, but at
least Gentoo uses a "ports" system that makes it less
of a nightmare. Of course I am biased because I do run
Gentoo on my laptop and would want the emulation base
to be compatible if I package up native Gentoo apps to
my FreeBSD system.


More information about the freebsd-questions mailing list