CUPS - Does not function anymore (Solved, mostly)

Sean M. sigma_zk at
Tue Aug 15 02:31:55 UTC 2006

I managed to track down the problems:
1) KPrinter overwrote cupsd.conf, fortunately I had a backup, which
made the Web usable again.
2) Some files were missing from the hplip installation. I forceupgraded
it, and I could delete and reinstall the printer, so it now works as it
did before.

I still can't get CUPS to work in KDE though. If anyone has any ideas
on that, please share them.

--- Rod Person <personrp at> wrote:

> On Sun, 2006-08-13 at 23:07 -0700, Sean M. wrote:
> > The story so far:
> > I had cups-1.2.2 and couldn't get KDE to use it with my HP PSC 1400
> and
> > hplip. I read somewhere that KDE was only reliable with cups 1.1,
> so I
> > downgraded CUPS to the last version before it was switched to
> 1.2.0.
> > That ended up breaking hpiod; so much for that. I had no choice but
> to
> > upgraded cups back to 1.2.2. I also replaced
> > /usr/local/lib/kde3/ with a symlink to
> > /usr/local/lib/
> > 
> > Now? Pretty much everything to do with printing is broken. If I go
> to
> > localhost:631, I get the CUPS welcome screen, but all the links
> load
> > for a long time then just stop. I used to at least print with LPD,
> now
> > that's gone:
> > 
> > A print error occurred. Error message received from system:
> > 
> > /usr/local/bin/lpr -P 'PSC_1400' '-#1'
> '/tmp/kde-sgm/kdeprint_zivvNqlK'
> > : execution failed with message:
> > /usr/local/bin/lpr: Unsupported format 'application/postscript'! 
> > 
> > I could also print with CUPS out of non-KDE apps like Firefox. Now
> they
> > just do nothing.
> > 
> > The printer is connected fine, because I can get its status and
> scan
> > with it from hp-setup. It pretty much looks like CUPS is screwed
> up,
> > and I can't figure out how to fix it. Could someone please help?
> > 
> This all happened to me when I also upgrade cups. I tried to go back
> an
> reinstall all the cups packages to see what would happen.
> Doing this I found that cups-lpr was broken and did not install. I
> manually made the sim links to /usr/local/bin/lpr, /usr/local/bin/lpq
> and /usr/local/bin/lprm (I believe that was all) as this is what had
> to
> be done in the old days before the cups-lpr port. After doing this I
> can
> now print from non-KDE apps using the lpr command. But krpinter still
> did not work with CUPS so I changed it to print with lpd and it now
> works.
> Rod

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the freebsd-questions mailing list