Need help! Apache core dumps when running startssl

Andreas Widerøe Andersen wodfer at
Mon Aug 7 18:40:02 UTC 2006

I recently upgraded one of my production servers to FreeBSD 4.11 p19 and
then upgraded all ports. I'm now running Apache 1.3.36 mod_ssl and Php 4.4.2

I had Squirrelmail running on https and now I can't start Apache with ssl.
Every time it coredumps. I've tried snakeoil and my own cert. Same thing

This is the error message I can see from my httpd-error.log:

[Mon Aug  7 20:20:03 2006] [notice] caught SIGTERM, shutting down

ssl-engine log:

[07/Aug/2006 20:29:01 16880] [info]  Server: Apache/1.3.36, Interface:
mod_ssl/2.8.27, Library: OpenSSL/0.9.8b
[07/Aug/2006 20:29:01 16880] [info]  Init: 1st startup round (still not
[07/Aug/2006 20:29:01 16880] [info]  Init: Initializing OpenSSL library
[07/Aug/2006 20:29:01 16880] [info]  Init: Loading certificate & private key
of SSL-aware server
[07/Aug/2006 20:29:01 16880] [info]  Init: Seeding PRNG with 136 bytes of
[07/Aug/2006 20:29:01 16880] [info]  Init: Generating temporary RSA private
keys (512/1024 bits)

from messages:

Aug  7 20:34:52 server /kernel: pid 17041 (httpd), uid 0: exited on signal
11 (core dumped)

That's it. I can't find any other logs and I can't tell what's wrong.

What could it be and what can I do? I have checked the httpd.conf file and
compared the previous version with the new dist. Same directives related to
ssl virtualhost as far as I can see.

Hope to get some input.

Thanks & Best regards,
Andreas W. Andersen

More information about the freebsd-questions mailing list