undefined symbol "__ctype_b_loc"

John Nielsen john at
Sat Aug 5 16:46:57 UTC 2006

Quoting Warren Block <wblock at>:

> On Fri, 4 Aug 2006, Xiao-Yong Jin wrote:
>> Hi all, after upgrading firefox and acroread, I got this when I tried
>> to use the plugin,
>> LoadPlugin: failed to initialize shared library 
>> /usr/X11R6/Adobe/Acrobat7.0/ENU/Browser/intellinux/ 
>> [/usr/X11R6/Adobe/Acrobat7.0/ENU/Browser/intellinux/ 
>> Undefined symbol "__ctype_b_loc"]
>> I have these lines in my /etc/libmap.conf,
>> # Acrobat7 with Mozilla/Firebird/Galeon/Epiphany/Konqueror/Kazehakase
>> [/usr/X11R6/Adobe/Acrobat7.0/ENU/Browser/intellinux/]
>>                       pluginwrapper/
>> Bug?  Or my configuration fault?
> My configuration is the same (with 6-STABLE as of yesterday) and I 
> get the same error trying to view PDFs within seamonkey.  This has 
> happened earlier this year, but I can't recall when it was fixed or 
> if it was avoided by backing down to a previous version of acroread.

I saw this behavior with the acroread-7.0.4 (or was it 7.0.5?) port as 
well. That revision of the port was backed out before it had been in 
the tree very long since it wouldn't allow you to print. The port was 
reverted to 7.0.1, and recently made the jump to 7.0.8, thus bringing 
back the new symbol that linuxpluginwrapper doesn't understand. The 
advice to file a PR and let nork@ have some time to look at it is sound.


More information about the freebsd-questions mailing list