strange behavior webpages

Guido Demmenie rottweilertje at
Fri Aug 4 11:31:45 UTC 2006


I have a very strange problem with my served webpages.
When I open the webpages from my server with my ibook, while  
connected to my wireless network, everything goes fine. But when I  
refresh a website or when Safari is not grabbing it from its cache  
the page returns corrupted. The page shown is a bunch of random  
characters. After each refresh the stream of charachters is changed.  
On my PC the page is still corrupted, but with a refresh the  
characters are still the same.
When I open a terminal screen on my server and look at the file this  

%less data/www/networkstats.html
"data/www/networkstats.html" may be a binary file.  See it anyway?


%file data/www/networkstats.html
data/www/networkstats.html: data

After some time (about a day or so) the file gets back to its normal  
state, being a html file and it is served well again.
I thougth it would be a problem of my ibook, but when I connect to  
the website while using my wired network the problem does not occur.  
Also not when I am connected to a wireless network other than my own.  
Webpages served from my secure webserver don't get messed up, also  
dynamic pages (CGI/PHP) don't get messed up exept for the images that  
are on those pages.
For my wireless connection I use a wireless PCI card (Netgear MA311  
with latest firmware) on the serverside and the airport extreme from  
my ibook G4. The connection is WEP encrypted by standard FreeBSD  
I already tried to use a different version of apache (currenty using  
apache-2.0.55_4), but it didn't fix the problem.
I tried finding a useful error or things in my logfiles but I can't  
find anything.
I suspect some of the drivers for my wireless device (wi) to corrupt  
the files, problem is that even if I chmod 000 a file it still gets  

I use:
FreeBSD 6.0

some dmesg output:
FreeBSD 6.0-RELEASE #0: Wed Mar  8 19:48:39 CET 2006
CPU: Intel(R) Celeron(R) CPU 2.66GHz (2668.41-MHz 686-class CPU)
wi0: <Intersil Prism2.5> mem 0xfafff000-0xfaffffff irq 21 at device  
10.0 on pci1
wi0: using RF:PRISM2.5 MAC:ISL3874A(Mini-PCI)
wi0: Intersil Firmware: Primary (1.1.1), Station (1.8.4)

Can anyone help me on this, or does anybody has some kind of the same  

Guido Demmenie

More information about the freebsd-questions mailing list