[SOLVED] X11+ssh+jail

Micah micahjon at ywave.com
Thu Aug 3 23:29:44 UTC 2006

Micah wrote:
> I'm having problems trying to get X11 to forward from an ezjail created 
> jail environment. Here's what happens:
> trisha% ssh -X
> ...
> test% xclock
> X11 connection rejected because of wrong authentication.
> X connection to test:10.0 broken (explicit kill or server shutdown).
> I added "X11UseLocalhost no" to sshd_config as suggested on the lists a 
> while back, but it didn't change anything.
> Host is:
> trisha# uname -a
> FreeBSD trisha.eidolonworld 6.1-RELEASE-p3 FreeBSD 6.1-RELEASE-p3 #1: 
> Sat Jul 15 15:48:17 PDT 2006 
> root at trisha.eidolonworld:/usr/obj/usr/src/sys/TRISHA  i386
> Thanks,
> Micah

Okay, it took me half a day to trip over the solution. The other half a 
day was spent trying to figure out what that solution actually was. It 
was a combination of two things (out of the dozen that I tried) that 
weren't set up correctly.

The jailed system must be able to resolve it's own name to an IP 
address. Since my home network does not have DNS, that meant adding 
"  test" to /etc/hosts on the jailed environment. Also, 
"X11UseLocalhost no" must be set in the jailed sshd_config. Unless 
*both* of those are set properly, I get the error as mentioned above.


More information about the freebsd-questions mailing list