permissions dilemma

Duane Whitty duane at
Sat Apr 29 01:11:28 UTC 2006

jekillen wrote:
> On Apr 28, 2006, at 5:38 PM, Gerard Seibert wrote:
>> jekillen wrote:
>>> Hello:
>>> I have had a problem with installing MySQL 5.0.18 on a FreeBSD v 6.0
>>> installation
>>> where everything seems to compile and install correctly but the server
>>> crashes
>>> immediately on start up with permission to create/write it's .pid file
>>> denied.
>>> Then the screen saver daemon refuses to start in X windows with a
>>> permission denied
>>> error. It originally worked fine. But at some point recently the screen
>>> saver quit working.
>>> When I went to Gnome preferences and tried to set the screen saver I 
>>> was
>>> informed that the screen saver daemon wasn't running. When I tried to
>>> have it
>>> start I was presented with the permission denied error and to check the
>>> $path
>>> variable.
>>> I tried installing MySQL twice, each time with the same problem.
>>> As I understand it, permissions in Unix are part of the file system
>>> format.
>>> The only possible link between MySQL and the screen saver daemon,
>>> possibly, is the
>>> mysql user needed to run mysqld.
>>> Could I have a corrupted file system in such a way as to cause
>>> permission problems?
>>> thanks in advance.
>>> JK
>> Are you starting MySQL with the script in /usr/local/etc/rc.d/ upon
>> bootup?
>> -- 
>> Gerard Seibert
>> gerard at
> Boy that was fast, I just posted this message a moment ago...
> No I was just testing it using the mysqld_safe --user=mysql & approach.

As you don't mention it explicitly, did you run "mysql_install_db 
--user=mysql" ?
I know the first time I installed MySQL I neglected to do so.  As well, 
do you also
have a mysql user and a mysql group defined?

Best Regards,

Duane Whitty
duane at

More information about the freebsd-questions mailing list