permissions dilemma

jekillen jekillen at
Sat Apr 29 00:30:45 UTC 2006

I have had a problem with installing MySQL 5.0.18 on a FreeBSD v 6.0 
where everything seems to compile and install correctly but the server 
immediately on start up with permission to create/write it's .pid file 
Then the screen saver daemon refuses to start in X windows with a 
permission denied
error. It originally worked fine. But at some point recently the screen 
saver quit working.
When I went to Gnome preferences and tried to set the screen saver I was
informed that the screen saver daemon wasn't running. When I tried to 
have it
start I was presented with the permission denied error and to check the 
I tried installing MySQL twice, each time with the same problem.
As I understand it, permissions in Unix are part of the file system 
The only possible link between MySQL and the screen saver daemon, 
possibly, is the
mysql user needed to run mysqld.

Could I have a corrupted file system in such a way as to cause 
permission problems?

thanks in advance.

More information about the freebsd-questions mailing list