Same error with all ports install!

Garrett Cooper youshi10 at
Sun Apr 23 16:28:07 UTC 2006

Right. Bill nicely summed up what I've sort of been trying to say within 
a few paragraphs, quite nicely I might add.


Bill Moran wrote:
> I want to direct the focus in the correct direction on this.
> Based on your described symptions, bad RAM is the _most_ likely cause.  There
> are other things that could cause it, however.
> So _before_you_do_anything_else_, run memtest86.  I recommend the standalone
> boot-from-CD version, as it's more thorough in its testing.  Let it run for
> at least _8_ hours (or until you see errors).  Any errors from memtest86 are
> bad.  Even just a few errors per hour is unacceptable.
> If memtest86 produces errors, you can then start experimenting with different
> chips in different slots.  After each change, use _memtest86_ to see if the
> problem is solved.  I don't recommend using port compiles to test your RAM,
> it's not a reliable approach.
> Also, read the docs on memtest86.  There's a lot of good advice on finding
> RAM problems.
> Garrett Cooper <youshi10 at> wrote:
>> Marwan,
>> Did you run memtest86+? That is the true tell-tale sign that  
>> something RAM-related does or does not work.
>> You may also have a bad slot on your motherboard, so moving the RAM  
>> around to try and get it to work is a good way to troubleshoot your  
>> given issue in compiling things.
>> If you do move the RAM chip, make sure to firmly place it in its  
>> destination slot. If you don't your computer will report errors with  
>> the RAM chip, which are erroneous to the problem that you currently  
>> have.
>> HTH,
>> -Garrett
>> On Apr 23, 2006, at 7:58 AM, Marwan Sultan wrote:
>>> Hello there,
>>>  Sorry for disturb,
>>>  I have changed the RAM to diffrent 256 1 chipset DDR.
>>>  and now, whenever I compile any port the following error shows,
>>> cc: Internal error: Segmentation fault: 11 (program as)
>>> Please submit a full bug report.
>>> See <URL:> for instructions.
>>> *** Error code 1
>>>  For whatever port!
>>>  Any Advise? is it a PC problem? not BSD?
>>> Marwan
>>>> Marwan Sultan wrote:
>>>>> Its 2 chipset RAM, each 256DDR total 512
>>>>> Running on Dell Optiplex Gx260. P4 2.5
>>>>> Do you think ram has something wrong! ? it should be like one ram  
>>>>> chipset? has the problem?
>>>>> I'll try them one at a time,
>>>>> Thanks for the advise,
>>>>> Thanks kevin, thanks Garrett
>>>>>> Marwan Sultan wrote:
>>>>>>> Hello Guys,
>>>>>>> I fresh installed FreeBSD 6.0R some wierd stuff going on!
>>>>>>> Firts: the box restarted from it self like 4 times, and
>>>>>>> /var/log/messages showing only one strange
>>>>>>> line (for me) which is
>>>>>>> Apr 22 01:10:46 box kernel: pid 5764 (cc1),
>>>>>>>                             uid 0: exited on signal 6 (core  
>>>>>>> dumped)
>>>>>>> then i ran fsck, it cleared some files, now its not
>>>>>>> restarting but, i'm not sure it will or it will not.
>>>>>>>  second problem: whenever i try to install any port,
>>>>>>> it gave an error msg during the make says:
>>>>>>> cc1 in free(): error: junk pointer, too high to make sense
>>>>>>> cc1 in malloc(): error: recursive call
>>>>>>> cc: Internal error: Abort trap: 6 (program cc1)
>>>>>>> Please submit a full bug report.
>>>>>>> See <URL:> for instructions.
>>>>>>> *** Error code 1
>>>>>>>  Anyone could Advise please?
>>>>>>>  Marwan
>>>>>> How many RAM chips?  Try them one at a time...
>>>>>> KDK
>>>>    Another thing: Check the capacitors on your motherboard. If  
>>>> they the tops are swelling (tops are not flat) or bursting  
>>>> (emitting yellow/orange dialectric) on the capacitors around the  
>>>> RAM/CPU, it's time to either call Dell or get a new machine. The  
>>>> fault with bad capacitors is a well known quality control problem  
>>>> and if you search google for those terms, maybe you can get some  
>>>> more information as to what it is and why it occurs.
>>>> -Garrett

More information about the freebsd-questions mailing list