mysql rc.d script

Jerry McAllister jerrymc at
Wed Apr 19 21:46:46 UTC 2006

> "Vlad GURDIGA" <gurdiga at> writes:
> > I have a FreeBSD 6-current build from almost the most recent source.
> > I have installed mysql41-server port and observed a strange behaviour:
> > as usual, I only have to put the mysqld_enable="yes" in my
> > /etc/rc.conf to have mysql server started at boot, but this time it
> > did not work. I've checked the script mode and it was OK, just like
> > other scripts in there, and like the Apache starter script that worked
> > fine and after i put enable_apache="YES" in rc.conf.
> > 
> > The only difference between mysql server starter script and others was
> > the missing ".sh" suffix. After I renamed mysql-server to
> > everything worked fine.
> > 
> > Is that OK?

If you mean is adding the '.sh' to the name OK, then yes.
That is what you are supposed to do, as well as check to make
sure it has execute permission.


> It should be okay.  It changes the way that the script is called a bit
> (details in "man rc"), but start and stop should be fine.  Just be
> careful when you upgrade.
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list