[Fwd: Re: Problem regarding Samaba-automonts.]

Alex Zbyslaw xfb52 at dial.pipex.com
Fri Apr 14 15:53:40 UTC 2006

[Reply from Jostein forwarded with permission].

On 4/14/06, Alex Zbyslaw <xfb52 at dial.pipex.com> wrote:
> Jostein Kjønigsen wrote:
> >Hi!
> >
> >I got a question regarding samba automounting in FreeBSD. I'm running
> >FreeBSD 6.0 and have Samba3 installed.
> >
> >Manual mounting works fine, but I do need to enter a password. This is
> >regardless if its a specific mount or mounting a /etc/fstab entry.
> >
> >As far as I've understood things, to get automounting working properly
> >(w/o the password request) I need to enter a few entris in
> >/etc/nsmb.conf. And so I've done.
> >
> >If I use lowercase letters for the[COMPUTERNAME] and
> >[COMPUTERNAME:USERNAME] section, it just gets ignored.
> >
> >If I use all uppercase, I get "syserror: connection reset by peer".
> >
> >I've tried a few combinations of various /etc/fstab capitalization and
> >/etc/nsmb.conf capitalizations, but to no avail. Either i get
> >"connection reset by peer", or I get a request for the password.
> >
> >
> Here's a working nsmb.conf, with names etc. suitably obfuscated.  You
> need to use upper case, because windows seems to need it.  Make sure
> that Windows actually exports your share - I can't help with that as I
> know next to nothing about it - the Windows techie does it :-)
> In this example, the addr= makes the connection actually happen to an
> alternative name for the server, which happens to be on a Gbit, rather
> than Mbit LAN.  I don't believe it's required, but you could use the
> proper DNS name for the windows server here - it might help.  I think
> you probably need that name to appear in /etc/hosts just in case DNS is
> unavailable when the machine reboots, if you do want to auto-mount.
> [SERVER01]
> addr=server01-alt
> password=thepassword
> password=theotherpassword
> [SERVER02]
> addr=server02-alt
> password=theotherpassword
> And fstab has e.g.
> //user.name at server01/thesharename /mount-point smbfs rw 0 0
> //otheruser.name/othershare /other-mount-point smbfs rw 0 0
> and mount /mount-point  or mount /other-mount-point works without
> password prompting.
> hth,
> --Alex

Hey Alex!

Seems like using lowercase names in /etc/fstab and capitalized names
in /etc/nsmb.conf worked fine as long as I ommitted the machineaccount
with the add= section.

Thanks for the help. I really appreciate the work you guys do and the
support for FreeBSD have always impressed me more than the actual OS

Happy easter!

Jostein @ gmail.com

When the going gets tough, the tough gets duct-tape.

More information about the freebsd-questions mailing list