I think I butchered my supfile - can anyone tell me why I get this result?

Jim Stapleton stapleton.41 at gmail.com
Wed Apr 12 11:45:37 UTC 2006

I used the examples as a basis, and a little trial and error if things
didn't work, so I eventually got a working supfile. However, it did
some weird stuff, even though this should be downloading 6.0 stable
(from what I can tell), I get errors in port builds (even without
optimisation flags).

On top of that, I tried to build my kernel, and when all was said and
done, and it booted, it said 7.0 current. Is there a problem in my
supfile, or is this just a "HTF did you manage that??" error?

I ran:
$ cvsup -g -L 2 /etc/supfile

*default host=cvsup13.us.FreeBSD.org
*default base=/var/db
*default prefix=/usr
*default release=cvs tag=RELENG_6
*default delete use-rel-suffix
*default date=2006.

# If you seem to be limited by CPU rather than network or disk bandwidth, try
# commenting out the following line.  (Normally, today's CPUs are fast enough
# that you want to run compression.)
*default compress

## Main Source Tree.
# The easiest way to get the main source tree is to use the "src-all"
# mega-collection.  It includes all of the individual "src-*" collections.
src-all tag=.
ports-all tag=.
doc-all tag=.


More information about the freebsd-questions mailing list