sysinstall won't write fs to new disk, bad magic number

Lowell Gilbert freebsd-questions-local at
Wed Apr 12 11:19:02 UTC 2006

Oliver Iberien <oliver-mailinglist at> writes:

> There was a thread about this a while ago, but it did not seem to end in a 
> solution... In any case, I have a 160GB Seagate drive that I was trying to 
> mount a partition on as /disk2. I went through the instructions in the 
> Handbook under "Formatting Media for Use With FreeBSD." No formatting seemed 
> to be happening, though. When I added it to fstab, something in KDE found it 
> and then failed to open it. mount shows that it has not been mounted, and if 
> I try to mount it:
> bsd# mount -u /dev/ad1s2c /disk2
> mount: /dev/ad1s2c on /disk2: specified device does not match mounted device
> bsd# mount /dev/ad1s2c /disk2
> mount: /dev/ad1s2c: Input/output error
> I looked at the previous thread and then tried:
> bsd# newfs /dev/ad1s2c
> /dev/ad1s2c: 52627.0MB (107780084 sectors) block size 16384, fragment size 
> 2048
>         using 287 cylinder groups of 183.77MB, 11761 blks, 23552 inodes.
> super-block backups (for fsck -b #) at:
>  160, 376512, 752864, 1129216, 1505568, 1881920, 2258272, 2634624, 3010976,
>  ...
>  107260480, 107636832
> cg 0: bad magic number
> I had two partitions on it, one to be used for linux later on. I tried 
> swapping them out, but no difference. 
> This drive worked under linux. Any ideas?

Sounds like you didn't write a disklabel on it.  
That's covered in the tutorial you mentioned...

More information about the freebsd-questions mailing list