Hang in 5.3, related to syslog-ng

Valerio daelli valerio.daelli at gmail.com
Wed Apr 12 06:56:05 UTC 2006

Hi all
we have a server with 5.3 (latest patches) with twelve jails.
One of these jails is a mail server (mail-jail), serving about 300 users,
writing a lot of logs to /var/log/maillog.
On the same server I installed a jail with syslog-ng (syslog-jail).
syslog-ng was configured to listen on the network and write to
a named pipe.
On the same jail I created a script to read from that named pipe
and insert the result to mysql, but I didn't start this script.
I was about to start this system of logging, so I modified
/etc/syslog.conf in the mail-jail inserting a line like this:

mail.*         @logger_with_syslog-ng.my.domain

then I restarted syslogd on the mail-jail sending a HUP signal.
Suddendly the system stopped responding to anything
(from ping to console, everything stopped).
I rebooted the server turning off the power and deleted that line in
Everything worked.
Could it be some issue related to a named pipe?
Or pheraps to syslogd? Or syslog-ng?
I tried recreating the situation on a test server with 5.4 but
everything worked.
Sorry if I don't have details but this is a very critical server for us
and I can't experiment.

Valerio Daelli

More information about the freebsd-questions mailing list