Solved (I hope): Toggling port dependencies

Erik Norgaard norgaard at
Tue Apr 11 15:10:29 UTC 2006

RW wrote:
> On Tuesday 11 April 2006 13:25, RW wrote:
>> You could try  setting USE_OPENLDAP_VER=23 for the port.
> Actually, I see it conflict with 2.2, so it must be set globally.

Yes, OpenLDAP 2.3 conflicts with 2.2, but jabberd by default assumes 2.2
so the build fails. Then rather than downgrading OpenLDAP since 2.3 is
the recommended I'd prefer to force jabberd to build against 2.3.

I've seen many ports doing this, for example squid. Some announces how
to select a particular version. I don't know if your hint work with all

I tried your advice and things compiled and installed without any
problems - now the question is if it works ...

Thanks, Erik
Ph: +34.666334818                                  web:
S/MIME Certificate:
Subject ID:  9E:AA:18:E6:94:7A:91:44:0A:E4:DD:87:73:7F:4E:82:E7:08:9C:72
Fingerprint: 5B:D5:1E:3E:47:E7:EC:1C:4C:C8:3A:19:CC:AE:14:F5:DF:18:0F:B9

More information about the freebsd-questions mailing list