src upgrade from 4.11-p16 to 5.4 possible?

B. Cook bcook at
Fri Apr 7 13:27:23 UTC 2006

Hello all,

I am running a set of 5 FreeBSD 4.11 p16 servers here at the library.

For various reasons we are unable to 'get new drives' and install 
FreeBSD 5/6 and then migrate userland data to a new drive.

I have been able to get my hands on a test box from someone to test src 
upgrading from 4.11 to something more current like 5.x and then updating 
from there.

My standard running machines are Dual 933 Intel machines, 1G ram, scsi 
drives.. etc

This test box is an AMD Mobile Sempron 2600+ w/ 512M ram, 80G ide drives. is the guide 
that I am following.. and I have done what I think are the right steps.. 
and I am getting a crash/failure in a most unusual place.

Stop in /usr/src/usr.sbin/pcvt/vgaio.
*** Error code 1

===> usr.sbin/pcvt/ispcvt
cc -O -pipe   -c /usr/src/usr.sbin/pcvt/ispcvt/ispcvt.c
cc -O -pipe    -o ispcvt ispcvt.o
gzip -cn /usr/src/usr.sbin/pcvt/ispcvt/ispcvt.8 > ispcvt.8.gz
===> usr.sbin/pcvt/vgaio
cc -O -pipe  -I/usr/obj/usr/src/usr.sbin/pcvt/vgaio 
-I/usr/src/usr.sbin/pcvt/vgaio  -c vgaio.c
In file included from /usr/src/usr.sbin/pcvt/vgaio/vgaio.y:56:
/usr/obj/usr/src/i386/usr/include/machine/cpufunc.h:60: error: syntax 
error before "bsfl"
/usr/obj/usr/src/i386/usr/include/machine/cpufunc.h:60: error: syntax 
error before "mask"
/usr/obj/usr/src/i386/usr/include/machine/cpufunc.h: In function `bsfl':
... etc

The strange thing is this:
CPU: Mobile AMD Sempron(tm) Processor 2600+ (799.92-MHz 686-class CPU)

this is what dmesg tells me about this cpu.. again this is under 4.11

So I am wondering if these things are related, and if I try this on an 
Intel cpu will I still have this issue?

As my cvsup to RELENG_5_4 and then make buildworld fails at this point.

I have script'd the make buildworld which is a 9M text file, and it 
compresses down to a ~500k bz/gz file if anyone is interested in it.

I have tried in single user mode as well again no difference.  I have 
tried make -j4 buildworld (only gets there faster.. )

Thanks in advance any help is greatly appreciated.

(I'm going to try 5.3 and then if that doesn't work then I'll try 5.2.1)

- Brian

More information about the freebsd-questions mailing list