Running an X application as root? (getting printer set in openoffice)

Oliver Iberien oliver.iberien at
Fri Apr 7 04:00:00 UTC 2006

No... I didn't know about the cups option for openoffice. I find it mentioned, 
now that you mention it, at . I 
now see that the option's existence can also be extrapolated from the code 
in ./files/Makefile.knobs. 

I had no idea that "knob" meant a make option. (The term appears twice in the 
whole of the FreeBSD Handbook (in sound-setup.html and firewalls-ipfw.html), 
which has been my main source of information.) I wonder if the Makefile.knobs 
file is what is read for the blue options screen that sometimes appears to 
provide choices before compiling.

My workaround is to use the command kprinter. So openoffice drags up kprinter 
and adds an extra step. It's kind of annoying, but I'll wait till an upgrade 
of OpenOffice comes along before I compile it (and compile it, and compile 
it) again.


On Thursday 06 April 2006 20:26, Duane Whitty wrote:
> Oliver Iberien wrote:
> > In order to set the printer setting for I have to,
> > as far as I know, run the program
> > /usr/local/ as root. (The default
> > settings are for lp and I am using cups.) It's a series of dialogs in
> > windows and so I've tried to set the display. I get a "no protocol
> > specified" error.
> >
> > bsd# setenv DISPLAY ":0.0"
> > bsd# /usr/local/
> > Xlib: connection to ":0.0" refused by server
> > Xlib: No protocol specified
> >
> > I18N: Operating system doesn't support locale "en_US"
> > Xlib: connection to ":0.0" refused by server
> > Xlib: No protocol specified
> >
> > /usr/local/ X11 error: Can't open
> > display: :0.0
> >    Set DISPLAY environment variable, use -display option
> >    or check permissions of your X-Server
> >    (See "man X" resp. "man xhost" for details)
> >
> > I looked at the xhost page and tried:
> >
> > bsd# xhost +root
> > Xlib: connection to ":0.0" refused by server
> > Xlib: No protocol specified
> >
> > The same thing happened with xhost +. What am I missing?
> >
> > Oliver
> >
> > PS Using sudo does not work as for some reason when I try to run spadmin
> > with sudo, spadmin can't find libraries it needs that are in its own
> > folder. su-ing gets the same result as running as root, and deleting
> > ~/ and running spadmin as a normal user changes
> > nothing -- apparently nothing printer-related is in there.
> > _______________________________________________
> When you built OOo did you use the -DWITH_CUPS option?

More information about the freebsd-questions mailing list