PXEboot install failing to load kernel

Chris twidds at gmail.com
Wed Apr 5 19:46:01 UTC 2006


I am trying to perform a netboot install of FreeBSD 6  to a Thinkpad
X40 laptop from linux on my desktop. I've followed what guides I can
but the info is either for older versions of FreeBSD (the CD structure
has changed?) or assumes an existing FreeBSD install to work from (for
dissecting floppy images etc).

I have downloaded the i386 bootonly iso and I have followed portions
of several guides which has got me as far as tftp serving the pxeboot.
I assume the dhcp and tftp parts are working ok as the laptop gets
hold of pxeboot fine but then fails to load the kernel.

I have tried nfs serving the boot directory of the cd and the kernel
directory within that without any luck, is the kernel passed by tftp
or nfs? I have tried tailing var/log/daemons but the failure to load
kernel message on the laptop is the only useful indicator I get.

Any help to get me further along appreciated,


More information about the freebsd-questions mailing list