jls shows dead jails too?

Chad Leigh -- Shire.Net LLC chad at shire.net
Tue Apr 4 20:14:09 UTC 2006

On Apr 4, 2006, at 2:03 PM, Kris Kennaway wrote:

> On Tue, Apr 04, 2006 at 04:21:39PM -0300, Marc G. Fournier wrote:
>> On Tue, 4 Apr 2006, Chad Leigh -- Shire.Net LLC wrote:
>>> On Apr 4, 2006, at 9:20 AM, Daniel Johansson wrote:
>>>> I'm setting up a few jails on my FreeBSD 6.0 box and when I run  
>>>> jls to
>>>> list my jails it shows all my started jails.
>>>> The problem is that when I kill a jail with kill -TERM -1, thats  
>>>> what the
>>>> man page tells me to use, it still is listed when I run jls. Why  
>>>> is that
>>>> and is there any way to clear the jls list? Where does jls get  
>>>> the list
>>>> of the jails?
>>> The jail is not completely did in that case.  It still "owns" some
>>> resources of some sort.
>> Is there some way of finding out what resources?  Right now, on  
>> one of my
>> boxes:
>> # jls
>>    JID  IP Address      Hostname                      Path
>>      4  mx2.hub.org                   /vm/1/ 
>> mx2.hub.org
>>      2  mx2.hub.org                   /vm/1/ 
>> mx2.hub.org
>>      1  mx2.hub.org                   /vm/1/ 
>> mx2.hub.org
>> It doesn't bother me too much, as 1/2 doesn't appear to be  
>> affecting 4,
>> but still ...
> See my reply.

Other things that I have seen are if you have a FS mounted inside  
your jail and that did not umount completely or appropriately, for  

For example, I use file backed md devices as jail file systems and I  
mount various pieces of a master jail inside my jail.  If I do not  
umount everything cleanly before shutting the jail down it remains  
listed in the jls list


Chad Leigh -- Shire.Net LLC
Your Web App and Email hosting provider
chad at shire.net

More information about the freebsd-questions mailing list