flash plugins question

Joseph Vella satyam at sklinks.com
Sat Apr 1 21:42:14 UTC 2006

On Saturday 01 April 2006 09:44, Paul Schmehl wrote:
> --On April 2, 2006 12:51:59 AM +0800 Marlon Martin <mmp013 at gmail.com> wrote:
> > linuxpluginwrapper is installed from ports, and linux-flashplugin7 after
> > that i copy libmap.conf-FreeBSD6
> > from<file:///usr/local/share/examples/linuxpluginwrapper/libmap.conf-Free
> > BSD6> /usr/local/share/examples/linuxpluginwrapper/  to /etc/ and rename
> > it as libmap.conf but still no plugins for flash: when typing:
> > "about:plugins"
> >
> Ditto.  And no java plugins either.  I've make deinstalled/installed so 
> many times my head is spinning.
> I installed mplayer and viola!!!  the plugins were "registered" with 
> firefox.  Why can't java and flash do that?
> And yes, I've read the man pages, goggled, searched the fbsd lists, tried 
> the millions of different "solutions" that "worked" for various people. 
> Everything else on FreeBSD "just works".  Why can't the damn browser 
> plugins?

I had to symlink the plugins:

from  /usr/X11R6/lib/linux-flashplugin6/flashplayer.xpt 
to /usr/X11R6/lib/browser_plugins/flashplayer.xpt

from /usr/X11R6/lib/linux-flashplugin6/libflashplayer.so
to /usr/X11R6/lib/browser_plugins/libflashplayer.so

In your case they're probably in linux-flashplugin7

More information about the freebsd-questions mailing list