problems with cd/dvd-device

Roland Smith rsmith at
Tue Oct 25 06:27:26 PDT 2005

On Tue, Oct 25, 2005 at 02:19:04PM +0200, Linnea Forslund wrote:
> On 10/25/05, Greg 'groggy' Lehey <grog at> wrote:
> > On Tuesday, 25 October 2005 at 14:04:25 +0200, Linnea Forslund wrote:
> > > I know, I know. I ask a lot of questions right now, but it's just
> > > because I've waited until it's very acute until I got myself to start
> > > fixing these things.
> > >
> > > So, I can't seem to find my cd/dvd-device. What do I do?
> >
> > That depends on what you've already done.  What did you do?
> >
> > Greg
> Well, what "I" did originally I didn't do. Someone else did and I feel
> a bit handicapped not knowing what's reallt been done and not. Now I
> tried som commands in the newbie guide like these:
> supermoccine# mount /cdrom
> cd9660: /dev/acd0: Invalid argument
> supermoccine# /sbin/mount_cd9660 /dev/cd0a /cdrom
> mount_cd9660: /dev/cd0a: No such file or directory

That should be /dev/acd0 or /dev/cd0, not /dev/cd0a.

Check that CD devices are actually there, with "ls /dev/*cd*". On my
system this returns: "/dev/cd0 /dev/cd1" but that's because I use SCSI
emulation. A system with a GENERIC kernel would probably show /dev/acd0.

> And I tried inserting a cd with musicfiles and find it from xmms, but
> there was nothing in /cdrom.

Playing music is very different from mounting, so that's perfectly normal.

R.F.Smith ( Please send e-mail as plain text.
public key:
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list