root can't write to NFS mounted directory

Erik Norgaard norgaard at
Tue Oct 18 23:54:59 PDT 2005

On Tue, 18 Oct 2005, Mohan Singh wrote:

> The users who log in via NIS can write to their respective home
> directories, but root on the NFS client can't.
> The NFS directories are exported via a NAS. I know it is not a
> configuration issue on the NFS server, as it previously worked fine,
> and the only change I have made recently is to wipe and install the
> client.
> What setting on the client allows root to write to NFS mounted directories?

This behaviour is expected if you haven't set maproot on the 
server. By default the server will map the root user on the 
client to nobody on the server. On the server set --maproot=root 
to give root on the client access as root on the server.

- I know you write that it worked and you haven't changed anything 
on the server, but check it anyway.

Anyway, it is not recommended to use --maproot, in particular not 
for write mounted shares as there is no authentication.

Cheers, Erik

More information about the freebsd-questions mailing list