NIS on FreeBSD 5.4/4.11

Michael Jeung mjeung at
Wed Oct 12 18:07:22 PDT 2005

Good evening all,

I am desperately trying to get NIS working in my FreeBSD 5.4 and 4.11  
environment - specifically, I'm trying to get NIS set up such that a  
NIS client is able to change the password for an account.

Like a good little rabbit, I have followed, step-by-step the NIS  
guide in the handbook: 

In my test environment, I have two servers set up: BoxA and BoxB.   
BoxA is the NIS Master running 5.4, BoxB is the NIS client running  
4.11.   I have created a NIS user named "charlie" on BoxA.   I am  
able to log into BoxB as charlie.  Great so far, right?  ypcat  
demonstrates that the correct user on BoxB is coming down and ypwhich  
passwd shows that BoxA is BoxB's daddy.

Now, I want to be able to change "charlie"'s NIS password while I'm  
logged into BoxB.  Here's where I run into problems.  Whenever I run  
yppasswd or passwd as charlie, I get "Permission Denied."  I know  
I've run into this error before (without ever being able to fix it)  
and after googling for quite some time, I've been unable to find  
anyone else who seems to be running into this problem -- but I know  
other people must have encountered this before, because I'm not doing  
anything fancy.  This is the most vanilla install of NIS I can create.

If anyone has any hints on where I should look from here, I would  
very much appreciate it!

Michael Jeung

More information about the freebsd-questions mailing list