Which MySQL version best to use and with/without linux threads?

Peter Giessel pgiessel at mac.com
Thu Oct 6 08:30:22 PDT 2005

On Thursday, October 06, 2005, at 07:22AM, Greg 'groggy' Lehey <grog at FreeBSD.org> wrote:
>> *** MySQL Log 4.1.14 ***
>> 051002 17:41:47       1 Connect     Access denied for user 'abbc'@'localhost' (using password: YES)
>This is the same authentication problem seen from the other side.
>> 051002 17:42:08       2 Connect     abbc at localhost on
>And this
>> *** End Log Snipet ***
>> *** MySQL Log after downgrading (4.0.26) ***
>> 051003  8:53:56       5 Connect     abbc at localhost on aukebay
>And this is the next day.  It looks as if it worked.

Yes, it worked after the downgrade was complete, but the 051002 17:42:08 connection
was the same day, the same time frame (21 seconds later).  It worked from the
command line, but not from Dovecot.

>> *** End Log Snipet ***
>> The 17:42:08 connection is when I:
>> # mysql -u abbc -p
>> logged in from the command line using the password in the dovecot config file.
>> I didn't touch the dovecot config file after downgrading, and I used the same
>> .sql file to populate the database with both version of MySQL, so the password
>> was unchanged.
>So you're saying that the authentication problem was despite proven
>good user name and password?

Yes.  That is exactly what I'm saying.

>It's not clear that there was anything wrong on the morning of 3
>October.  Did you give up or continue?

I deinstalled 4.1.14 later on the 2nd and started recompiling 4.0.26.
I finished installing and fixing downgrade issues on the 3rd, at which
time dovecot connected successfully.

>There have been some changes to authentication (in particular,
>password hashing) between 4.0 and 4.1.  It's possible that you need to
>do something to your Dovecot configuration, but unfortunately I don't
>know Dovecot at all.

I'm not saying anything is wrong with 4.1, I was just trying to point
out that there *may* in some cases be compatibility issues with 4.1.

It doesn't *always* play nice with others, as the OP claimed, and as
you say, its probably a dovecot issue, but downgrading solved it

More information about the freebsd-questions mailing list