Perl / Webmin: issue

Mark Edwards mark at
Tue Oct 4 05:54:01 PDT 2005

On Oct 3, 2005, at 4:20 PM, Lowell Gilbert wrote:

> Mark Edwards <mark at> writes:
>> On Oct 3, 2005, at 1:33 AM, Lowell Gilbert wrote:
>>> Mark Edwards <mark at> writes:
>>>> I am getting the following error in the browser when trying to use
>>>> webmin's crontab editing feature:
>>>> /usr/libexec/ /usr/local/bin/perl: Undefined symbol
>>>> "PL_exit_flags"
>>>> crontab: "/usr/local/lib/webmin/cron/" exited with
>>>> status 1
>>>> I am running perl 5.8.7 from ports, and I have done the whole  
>>>> routine
>>>> with setting use.perl port and perl_after_upgrade.
>>>> I notice that there are two /usr/libexec/ files on my
>>>> machine:
>>>> -r-xr-xr-x  1 root  wheel    85940 Feb 11  2005
>>>> -r-xr-xr-x  1 root  wheel    85908 Jun 29  2004
>>>> Is that normal?  I reinstalled the perl port to no avail.
>>> Are your ports up to date?
>>> [From an up-to-date ports tree?]
>> Yes, up to date from cvs as of a week ago or so.  Can anyone suggest
>> a way for me to troubleshoot what exactly the problem is?
> Well, that symbol is definitely supposed to be present in your perl
> executable.
> [E.g.,
> [  > strings /usr/local/bin/perl|grep exit_fl
> [  PL_exit_flags
> [  >
> Do you have any perl-related knobs in make.conf, or in pkgtools.conf
> (if you used portupgrade for installing)?

Well, I get the same result when I run the above command.  I suspect  
that it isn't perl itself that is the problem, but rather another  
port or an issue with my system.

One thing I wonder is about how I did my last system upgrade.  I did  
it long-distance, and so was unable to boot into single-user mode, so  
I just shut everything down and did the make installworld live, and  
then rebooted.  I wonder if something wasn't done correctly then,  
although I didn't get any complaints from the process, that I was  
aware of.

The other possibility is that this is a problem with webmin, although  
that doesn't seem likely since this error seems to indicate something  
broken with perl.  Still, why is this the only place where the error  
is showing up?  Lots of other stuff uses perl on my machine -- exim,  
spam-assassin, etc.

My /etc/make.conf is pretty simple:

lilbuddy:/usr/src paimin$ cat /etc/make.conf
CFLAGS= -O -pipe
NOPROFILE=     true    # Avoid compiling profiled libraries
MAKE_IDEA=     YES     # IDEA (128 bit symmetric encryption)



# port settings
.if ${.CURDIR:M*/mail/exim}

# added by use.perl 2005-09-30 16:58:27

Mark Edwards
mark at
cell: +46704070332

More information about the freebsd-questions mailing list