What's changed re: ACPI for 6.0??

Kevin Kinsey kdk at daleco.biz
Mon Oct 3 17:41:54 PDT 2005

Hi list ....

I don't ask too many questions, but after scratching my head a
bit, trawling through Google, some of the mailing list archives,
/usr/src/UPDATING, and most of the contents of /sys/i386/conf,
I'm still not sure what's up; however, I've ascertained that PEBKAC
instead of the kernel code, which ought to be good news to those
concerned with R.E.  (had one "aha!" moment prior to hitting SEND
on that e-mail....)

I just updated from 5.4 -> 6.0BETA5 about a week and a half ago.

On 5.4, ACPI and "shutdown -p" Just Worked.  On 6.0, it didn't:

         link_elf: symbol ioapic_enable_mixed_mode undefined
         KLD file acpi.ko - could not finalize loading

However, a hour ago or so, I figured "what the heck, let's just put
`device acpi` back into the kernel.  Make, Make installkernel, and
all's peachy.  :-)

So, what did I miss?  I'd like to think that it was just that the 
wasn't up to date with the code, but more likely it's just that my brain
isn't working properly.

If I could beg enlightenment for my sanity and also for future reference,
what's changed/what did I miss?

Donning my asbestos leotards,

Kevin Kinsey
DaleCo, S.P.

More information about the freebsd-questions mailing list