SV: /usr/libexec/ /usr/local/lib/ Undefined symbol "stpcpy"

Thomas Uhrfelt thomas.uhrfelt at
Tue Nov 29 21:04:33 GMT 2005

Thanks, but shouldn't that really be in the handbook? I ran out of time
today and since it's a production system I need to wait until tomorrow to se
what happens. Would it kill me to use packages (fetch) when doing this?

-----Ursprungligt meddelande-----
Från: Kris Kennaway [mailto:kris at] 
Skickat: den 29 november 2005 21:59
Till: Thomas Uhrfelt
Kopia: freebsd-questions at
Ämne: Re: /usr/libexec/ /usr/local/lib/ Undefined
symbol "stpcpy"

On Tue, Nov 29, 2005 at 03:43:14PM +0100, Thomas Uhrfelt wrote:
> Dear fellow FreeBSDers,
> I have recently started to get the message in the subject when installing
> ports from source. I have scanned the mailinglists and other resources and
> found a few others with these particular problems. And I've tried most of
> the tricks mentioned there (excluding those which sounds a bit dangerous
> conduct on a semi-production system) - including reinstalling gettext etc.
> do not have the Compat4X clause in make.conf so this shouldn't be part of
> problem.
> This is a 5.4-Stable machine upgraded from 4.8 during the summer, and so
> it conducted and performed extremely well.  I am rebuilding the world and
> kernel right now against the latest 5.4-STABLE sources. Then I am going to
> try a portupgrade  -fa, but if this doesn't permanently solve my problems,
> would like to hace som suggestions on where to go next.

Yes, you need to portupgrade -fa whenever you upgrade to a new major
release of FreeBSD.  At the moment you have an inconsistent mix of 4.x
and 5.x libraries, and that is a recipe for disaster.


More information about the freebsd-questions mailing list