FreeBSD 5.4 Via Unichrome / CLE266 Xorg hardware mpeg decoding

Vincent The vincent at
Sat Nov 26 13:28:36 GMT 2005


I'm kind of lost after all the searching and trying the different "solutions".

The situation: I have a motherboard with the Via Unichrome Integrated
Graphics which should support hardware mpeg2 decoding, a feature I
really need on this box. I'm running FreeBSD 5.4 Release with xorg 6.8.2
from ports.

For the past two day's I've tried a number of possible solutions to get
it to work, I do get X to work, but not with hw-mpeg-acceleration. Among
the things I've tried:

The error I'm getting at this point is : [drm] failed to load kernel
module "via" (EE) VIA(0): [dri] DRIScreenInit failed.   Disabling DRI

Apparently Unichrome doesn't support hw-mpeg-decoding anymore, on the
other hand I don't have a clue on how to use the Openchrome alternative.

For the record, I only need hw-mpeg-decoding in combination with
mplayer, so if there's a solution that doesn't need X at all it would be
even better.

Can anyone give me some pointers to get hardware mpeg decoding to run
in conjunction with mplayer? Whether it is via the kernel module, or
any other option, I just need it to work.

Thanks in advance,

Vincent The

More information about the freebsd-questions mailing list