HELP! ports messed up

cs cs-fbsd at
Mon Nov 21 15:14:32 GMT 2005


On a FreeBSD 5.4-RELEASE-p7 machine I maintain a partial port tree by 
using "porteasy -u foo" to pull in new ports when needed and a daily 
periodic script to do update /usr/ports as follows:

	cd /usr/ports
	cvs -f -q up
	make fetchindex
	/usr/local/sbin/portsdb -u
	/usr/local/sbin/pkgdb -Fa

The CVS/Root entry is: :ext:anoncvs at

Recently, I began to experience problem with the cvs repository above, 
error messages are (from 10 Nov):

	ssh: connect to host port 22:
		Operation timed out
	cvs [update aborted]: end of file from server
		(consult above messages if any)

and (from 14 Nov)

	Cannot access /home/ncvs/CVSROOT
	No such file or directory

I now am having problem with (I suspect) the port indices.

If I run "pkg_version -vL=", I get:

	fastest_cvsup-0.2.9_2  >   succeeds port (port has 0.2.9_1)
	p5-Class-DBI-3.0.12    >   succeeds port (port has 3.0.10)
	pear-PEAR-1.4.4        >   succeeds port (port has 1.3.5_1)
	phpbb-2.0.18           >   succeeds port (port has 2.0.17)
	subversion-1.2.3_3     <   needs updating (port has 1.3.0.r2)

while "portversion -vL=" produces:

	cyrus-sasl-2.1.21       <  needs updating (port has 2.1.21_1)
	m4-1.4.3                <  needs updating (port has 1.4.4)
	netpbm-10.26.18         <  needs updating (port has 10.26.19)
	p5-HTML-Parser-3.45     <  needs updating (port has 3.46)
	p5-HTML-Tagset-3.04     <  needs updating (port has 3.10)
	p5-PathTools-3.12       <  needs updating (port has 3.14)
	pear-apd-1.0.1,1        >  succeeds port (port has 0.9.2,1)
	php5-pear-5.0.5         <  needs updating (port has 5.0.5_1)
	phpMyAdmin-      <  needs updating (port has
	pkgconfig-0.19          <  needs updating (port has 0.20)
	postfix-2.3.20051014,2  <  needs updating (port has 2.3.20051118,2)
	ruby-1.8.2_5            <  needs updating (port has 1.8.2_5,1)
	snort-2.4.3             <  needs updating (port has 2.4.3_1)
	subversion-1.2.3_3      <  needs updating (port has 1.3.0.r2)
	sudo-            <  needs updating (port has
	webmin-1.240            <  needs updating (port has 1.240_1)
	zip-2.3_2               <  needs updating (port has 2.31)
	zoo-2.10.1              <  needs updating (port has 2.10.1_1)

If I do a "portupgrade zoo", it says:

	** No need to upgrade 'zoo-2.10.1' (>= zoo-2.10.1)

I have tried the followings but still cannot resolve this:

	pkgdb -Fu
	pkgdb -fu
	portsdb -Fu
	porteasy -ua

I dont think I can do a "portsdb -U" because my portage is partial (am i 
right ?)

Please HELP!


p.s. since I realized that is unavialble, I have 
switched to use, e.g. in the daily script I use:
"cvs -d:ext:anoncvs at -f -q up"

More information about the freebsd-questions mailing list