PHP stopped working :(

Matt Singerman matt.singerman at
Sun Nov 20 20:09:55 GMT 2005

Hi all,

I have a FreeBSD 6.0 system which had PHP4 running perfectly fine on it.
However, I wanted to install Horde (www.horde) with IMP, which requires IMAP
support, so I decided to try and recompile PHP using
/usr/ports/lang/php4-extensions, first running make deinstall in
php4-extensions and php4. At first, this did not work. I checked, and sure
enough, the old data for the compilation was in /var/db/ports, so I deleted
it out. Anyway, I ran make and make install in
/usr/ports/lang/php4-extensions without any problems, then I ran make and
make install in /usr/ports/lang/php4. This is where I first noticed things
looked a bit weird. It didn't seem like php4 was completely recompiling it;
that is, it didn't seem to take long enough. But it claimed to have worked
correctly, so I restarted Apache. Lo and behold, my problems started. First
off, and this is weird, my test file - a simple file containing only a
callto phpInfo() - will work in IE, but not in Firefox. Check it out:

Second, SquirrelMail won't load at all:

I have tried deinstalling and reinstalling PHP countless times now, with no
results. I checked my httpd.conf file, and all seems okay. Any ideas what
this could be? I'm very trustrated at this point, and am considering blowing
away Apache and starting it from scratch :(



More information about the freebsd-questions mailing list