pf + NAT loopback

J.D. Bronson jbronson at
Sat Nov 19 15:29:48 GMT 2005

I had all of this working with PPPoE + PF, but now i have a T-1
with several IPs all aliased off of the main.

pf is working fine....however, I now have lost NAT LOOPBACK.

What I need is a way to go from one LAN machine to the WAN and 
loopback to the other LAN machine.

Since this 'just works' with pppoe, how do I do it with pf?

simple pf.conf:

binat on $bge1 from to any -> 67.x.x.1
binat on $bge1 from to any -> 67.x.x.2
binat on $bge1 from to any -> 67.x.x.3
binat on $bge1 from to any -> 67.x.x.4
and so on.

I need to use to go and connect to public

This results in an immediate connection refused. I see nothing in the 
pflog and I even tried pass out quick all.

So I dont think pf is technically blocking it -but....

Why do I need this? - I run 2 external DNS servers (with views) and 
as such NS2 needs to talk to NS1 but using the WAN NAT loopbacks.


J.D. Bronson
Information Services
Aurora Health Care - Milwaukee, Wisconsin
Office: 414.978.8282 // Fax: 414.977.5299

-Taco Bell is *not* the Mexican Telephone Company-

More information about the freebsd-questions mailing list