Startx Missing Following Portupgrade

Robert H. Perry rperry at
Sat Nov 19 14:13:36 GMT 2005

I'm running FreeBSD 5.4-RELEASE #0 on two machines and just CVSup'd my 
systems last night finishing with portupgrade this morning.  I ran into 
a problem with machine #1.  I ran portupgrade and stumbled with the 
xterm and x11-fonts/linux-fontconfig upgrades.  I tried to run startx to 
google the problems but got: command not found.

Reinstalling linux-base seemed to resolve the x11-fonts problem.  I then 
   deinstalled, and reinstalled xorg-clients to upgrade it and ran 
portupgrade -aRr.  No more apparent problems.  However, still unable to 
run startx.  I searched /usr/X11R6/bin and couldn't locate the file either.

The second machine was also upgrading and I noticed the same/similar 
failure to install xterm 206_1 due to a conflict with xorg-clients.  I 
haven't attempted to fix it yet for fear of losing startx here also.

I'm thinking of deinstalling/reinstalling one, or more ports to 
reinstall startx on machine #1.  (Not sure which ones, however). Any 

Bob Perry

More information about the freebsd-questions mailing list