cannot get IP working between associated ath0 & AP, what to do?

Bryan White m0laria at
Fri Nov 18 07:56:20 GMT 2005

Tried turning deftxkey 1 too, same thing.  However when I turn off WEP 
on my router, I can connect to and ping the router, but I can't get 

Matt Emmerton wrote:

>>>I have an SMC PCMCIA wireless adapter, model SMCWCB-G, based on an
>>>Atheros 5212 chipset, in a laptop running a fresh install of FreeBSD
>>>The card associates fine, but then fails to send any IP packets in
>>>the air, or at least that's what I presume is going on. I cannot
>>>ping the AP, I cannot get a lease using DHCP, basically the only
>>>thing I can do is associate. I think it does associate because when
>>>I set an invalid wep key, t# Wireless NIC cards
>>>Setting a static IP address does not help.
>>>Any hints on where I might go from here to debug this? I know the
>>>setup should work because in a previous life [1] it Worked With
>>>Windows[TM] (and on the same AP).
>>>If it is using wep, set the weptxkey. I had the same problem when
>>>moving from a laptop with releng_5 to a laptop with releng_6.
>>I am having this same issue I believe in FreeBSD 6.0-RELEASE.  I have a
>>dwl-g650 "na.b5", h/w ver ":b5", f/w ver :2.54.  I compiled the
>>following into my kernel:
>>device          wlan            # 802.11 support  
>>device          ath             # Atheros
>>device          ath_hal         # Ath_hal
>>device          ath_rate_onoe
>>device          wlan
>>device          wlan_wep        # WEP support
>>I type in:
>># ifconfig ath0 channel 7 ssid gibsons wepmode on
>># ifconfig ath0 weptxkey *****etc.
>># ifconfig ath0 up
>># ifconfig ath0
>>        inet6 fe80::213:46ff:fe0f:3f66%ath0 prefixlen 64 scopeid 0x4 
>>        ether 00:13:46:0f:3f:66
>>        media: IEEE 802.11 Wireless Ethernet autoselect (DS/11Mbps)
>>        status: associated
>>        ssid gibsons channel 7 bssid 00:0c:41:a0:2c:46
>>        authmode OPEN privacy ON deftxkey UNDEF txpowmax 38 protmode CTS
>>        bintval 100
>># ifconfig ath0 inet
>># ping
>>I am unable to ping my router. (linksys bewfs42)
>>It seems like i'm missing something really simple here...anyone able to
>>help point me in the right direction?  Thanks.
>Maybe deftxkey needs to be set?
>Matt Emmerton

More information about the freebsd-questions mailing list