moused flags behaviour in 6.0 -- regression?

martinko martinkov at
Tue Nov 15 23:02:33 GMT 2005


until freebsd 6.0 (that is to say in 5.3 and 5.4) i used 
moused_flags="-3" in rc.conf and both my mice worked correctly (or as 
desired) -- synaptics touchpad missing 3rd button was emulated while the 
wheel on my USB mouse worked as expected.
now, in 6.0, with the same setting, touchpad 3rd button is emulated but 
USB mouse's wheel doesn't work. if i don't use the flag, USB mouse's 
wheel work but obviously there is no 3rd button on my touchpad. :-(
also, iirc back on 5.x even on wheel mouse the 3rd button could be 
emulated by pressing buttons 1 and 2, which is not possible now with 
wheel being on.

now, i know about moused_ums0_flags="", i'm just wondering why has this 
changed (to worse from my point of view).
also, at first i tried moused_psm0_flags="-3" but that didn't work as 
touchpad is apparently initialised without specifying psm0 device.

i hope i made myself clear (enough).



More information about the freebsd-questions mailing list