readline problems in FreeBSD 5.4/6.0

Bryan Maloney rafuzo at
Tue Nov 15 15:42:21 GMT 2005

Hi all,

I'm having some problems with readline on FreeBSD 5.4 and 6.0 - my lowercase 'x' has mysteriously disappeared (meaning it doesn't get read by readline). I run bash, mysql client and a couple other sundry utils that use readline, and they all exhibit this problem (and I discovered turning off readline use in bash with --noediting solves the problem - but readline is otherwise kinda handy and I'd like to keep it if I can make it work). I first noticed this when I went to portupgrade to the 11-10-05 dated readline port in ports - the first shell I opened up after the portupgrade completed exhibited this problem, as have all bash shells since (without readline disabled). Since then I haven't been able to shake it. I tried to back down the port to the prior version, I tried updating and rebuilding userland (am I right in thinking userland has a copy of readline all its own? Seems that way from what `find` says), manually linking to the older readline edition...I even went ahead with the upgrade to 6.0 as a desperation move, but nothing's changed. Shells and terminals aren't really my strong point so I'm pretty much out of ideas to try now. Any help would be greatly appreciated.


More information about the freebsd-questions mailing list