Lockup/Halt issues on FreeBSD-6.0-RELEASE

Josh Paetzel josh at tcbug.org
Sun Nov 13 02:09:14 GMT 2005

#uname -a
FreeBSD gimpy.tcbug.org 6.0-RELEASE FreeBSD 6.0-RELEASE #1: Fri Nov 11 
20:00:32 CST 2005     
jpaetzel at gimpy.tcbug.org:/usr/obj/usr/src/sys/GENERIC  i386

dmesg attached

This box has run 5.4-RELEASE-p(x) for quite some time without issue.  
I cvsupped it to 6.0-RC1 and that worked fine.  I cvsupped to 
6.0-RELEASE and that's when I started getting strange behaviour.

I run Xorg and fluxbox-devel with a large variety of apps. A typical 
mix is gaim, linux-opera, kate, kmail, xmms, xchat, gimp and a half 
dozen xterms for good measure.

Every once in a while the box will hang in a very strange way.  xmms 
plays music, irc stuffs scrolls on xchat, compiles on an xterm keep 
going, and the mouse pointer works.  The mouse buttons won't do 
anything, the keyboard won't do anything, I can't switch to a 
different virtual terminal, nothing is logged, I can't get to a 
debugger.  If I hit the power button (this is an ATX system) the box 
immediately shuts off.  On reboot it doesn't need to do an fsck of 
any kind nor does it complain about filesystems being unmounted 
improperly.  This sort of leads me to believe that somehow parts of 
shutdown are being run (or insert your theoretical theory here) I'm 
willing to do trouble-shooting on this if anyone is interested in 
looking at it.  I may be able to get a serial console when the hang 
occurs. (haven't tried that yet)


Josh Paetzel
-------------- next part --------------
Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 6.0-RELEASE #1: Fri Nov 11 20:00:32 CST 2005
    jpaetzel at gimpy.tcbug.org:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Sempron(tm)   2500+ (1767.87-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x681  Stepping = 1
  AMD Features=0xc0480800<SYSCALL,MP,MMX+,3DNow+,3DNow>
real memory  = 1072627712 (1022 MB)
avail memory = 1040748544 (992 MB)
ioapic0 <Version 0.3> irqs 0-23 on motherboard
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <KT600 AWRDACPI> on motherboard
acpi0: Power Button (fixed)
pci_link0: <ACPI PCI Link LNKA> irq 12 on acpi0
pci_link1: <ACPI PCI Link LNKB> irq 11 on acpi0
pci_link2: <ACPI PCI Link LNKC> irq 10 on acpi0
pci_link3: <ACPI PCI Link LNKD> irq 5 on acpi0
pci_link4: <ACPI PCI Link LNKE> on acpi0
pci_link5: <ACPI PCI Link LNKF> on acpi0
pci_link6: <ACPI PCI Link LNK0> on acpi0
pci_link7: <ACPI PCI Link LNK1> on acpi0
pci_link8: <ACPI PCI Link ALKA> irq 11 on acpi0
pci_link9: <ACPI PCI Link ALKB> irq 21 on acpi0
pci_link10: <ACPI PCI Link ALKC> irq 22 on acpi0
pci_link11: <ACPI PCI Link ALKD> irq 23 on acpi0
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x4008-0x400b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <VIA 8377 (Apollo KT400/KT400A/KT600) host to PCI bridge> mem 0xe0000000-0xe7ffffff at device 0.0 on pci0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
xl0: <3Com 3c905-TX Fast Etherlink XL> port 0xb000-0xb03f irq 18 at device 10.0 on pci0
miibus0: <MII bus> on xl0
nsphy0: <DP83840 10/100 media interface> on miibus0
nsphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
xl0: Ethernet address: 00:60:97:d8:ad:bd
pcm0: <Creative EMU10K1> port 0xb400-0xb41f irq 19 at device 12.0 on pci0
pcm0: <eMicro EM28028 AC97 Codec>
atapci0: <VIA 6420 SATA150 controller> port 0xbc00-0xbc07,0xc000-0xc003,0xc400-0xc407,0xc800-0xc803,0xcc00-0xcc0f,0xd000-0xd0ff irq 20 at device 15.0 on pci0
ata2: <ATA channel 0> on atapci0
ata3: <ATA channel 1> on atapci0
atapci1: <VIA 8237 UDMA133 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xd400-0xd40f at device 15.1 on pci0
ata0: <ATA channel 0> on atapci1
ata1: <ATA channel 1> on atapci1
uhci0: <VIA 83C572 USB controller> port 0xd800-0xd81f irq 21 at device 16.0 on pci0
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0xdc00-0xdc1f irq 21 at device 16.1 on pci0
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <VIA 83C572 USB controller> port 0xe000-0xe01f irq 21 at device 16.2 on pci0
usb2: <VIA 83C572 USB controller> on uhci2
usb2: USB revision 1.0
uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3: <VIA 83C572 USB controller> port 0xe400-0xe41f irq 21 at device 16.3 on pci0
usb3: <VIA 83C572 USB controller> on uhci3
usb3: USB revision 1.0
uhub3: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0: <VIA VT6202 USB 2.0 controller> mem 0xeb010000-0xeb0100ff irq 21 at device 16.4 on pci0
usb4: EHCI version 1.0
usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
usb4: <VIA VT6202 USB 2.0 controller> on ehci0
usb4: USB revision 2.0
uhub4: VIA EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
isab0: <PCI-ISA bridge> at device 17.0 on pci0
isa0: <ISA bus> on isab0
acpi_tz0: <Thermal Zone> on acpi0
fdc0: <floppy drive controller> port 0x3f2-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc0: [FAST]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
ppc0: <ECP parallel printer port> port 0x378-0x37f,0x778-0x77b irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/9 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
pmtimer0 on isa0
orm0: <ISA Option ROM> at iomem 0xc0000-0xcefff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ums0: Logitech USB-PS/2 Optical Mouse, rev 2.00/13.20, addr 2, iclass 3/1
ums0: 4 buttons and Z dir.
ugen0: vendor 0x046d Camera, rev 1.00/1.00, addr 3
Timecounter "TSC" frequency 1767869163 Hz quality 800
Timecounters tick every 1.000 msec
ad0: 114473MB <WDC WD1200JB-00GVC0 08.02D08> at ata0-master UDMA100
ad1: 190782MB <WDC WD2000JB-00GVA0 08.02D08> at ata0-slave UDMA100
acd0: DMA limited to UDMA33, device found non-ATA66 cable
acd0: DVDR <SONY DVD RW DRU-800A/KY03> at ata1-master UDMA33
ad3: 114473MB <WDC WD1200JB-00GVA0 08.02D08> at ata1-slave UDMA100
Trying to mount root from ufs:/dev/ad0s2a
xl0: link state changed to UP
nvidia0: <GeForce 6600 GT> mem 0xe8000000-0xe8ffffff,0xd0000000-0xdfffffff,0xe9000000-0xe9ffffff irq 16 at device 0.0 on pci1
nvidia0: [GIANT-LOCKED]
NVRM: detected agp.ko, aborting NVIDIA AGP setup!
NVRM: detected agp.ko, aborting NVIDIA AGP setup!

More information about the freebsd-questions mailing list