portmanager -slid core dumps

Danny MacMillan flowers at users.sourceforge.net
Fri Nov 11 23:03:42 GMT 2005

Michael C. Shultz wrote:
> On Friday 11 November 2005 14:21, you wrote:
>>On Friday 11 November 2005 13:35, Danny MacMillan wrote:
>>>Michael C. Shultz wrote:
>>>>On Friday 11 November 2005 12:55, Danny MacMillan wrote:
>>>>>I am experiencing further difficulties with portmanager -slid.  I was
>>>>>successfully able to delete several leaf ports.  However, when I try to
>>>>>delete devel/p5-Locale-gettext or devel/gmake, portmanager core dumps
>>>>>with the following message:
>>>>><n> Nuking gmake-3.80_2
>>>>>MGdbGoTop error: invalid object type, has this object been initialised
>>>>>with MGdbCreate or MGdbOpen yet?
>>>>>MGdbSeek error: invalid object type
>>>>>Assertion failed: (0), function MGdbSeek, file MGdbSeek.c, line 36.
>>>>>zsh: abort (core dumped)  sudo portmanager -slid
>>>>What version of portmanager?
>>>hobbit% sudo portmanager -v
>>>rCreateCommandLineDb 0.3.4_0 info: executing rm -f
>>>rParseCommandLine 0.3.4_0
>>OK, that is the most current version.  There isn't an obvious problem I can
>>see in the code but there is something that can be done better so I'll make
>>that change then we'll see what happens.  Are you running FreeBSD 6.0
>>by any chance?
> Opps, found the bug, it would only happen if you used the small "n", big N
> or x or X should work ok untill I get a patch out.  Thanks for reporting :)

Sorry, Mike.  For both devel/p5-Locale-gettext and devel/gmake, it
doesn't make any difference if I use 'n', 'N', 'x', or 'X'.  I still get
exactly the same error.

Danny MacMillan

More information about the freebsd-questions mailing list