adding a second hard drive

Dave Webster dwebman at
Fri Nov 11 19:47:20 GMT 2005

Thank you for the reply.  Your recommendation has worked and I now have
an additional hard drive on my system.  I was able to straighten out the
original drive  from some backups.  Every challenge in FreeBSD is such
an incredible learning experience.  Thanks once again.

On Fri, 2005-11-11 at 08:27 -0500, Lowell Gilbert wrote:
> Dave Webster <dwebman at> writes:
> > To solve a problem I'm having with /var running out of space, I decided
> > to add a second hard drive.
> > 
> > I found info at on adding disks using sysinstall and
> > followed the advice.  The old disk is a Maxtor 6Y080L0 80G as ad0 and
> > the new disk is a Maxtor 6Y120P0 as ad3.  I ran sysinstall, chose ad3
> > and parition it with: / 512M, /swap 2G, /tmp 3G, /var 4G, /usr
> > 30G, /data 76G.  Did an installation with Kern source and documentation.
> > Added a new user, and set a password for root.  I added the FreeBSD boot
> > manager.
> > 
> > I rebooted to ad0 (didn't have the FreeBSD boot manager on this drive
> > yet), and found I could no longer login as the regular user and that my
> > root password was the one I had just set up on ad3.  I adduser my old
> > login and assigned it the original ID and got back the settings in my
> > home directory, although I don't know what I've doen to the
> > configuration files in /etc.
> > 
> > I tried to put the FreeBSD boot manager on ad0 with:
> > boot0cfg -B ad0 but get an erro:
> > boot0cfg: open /de/ad0: no such file or directory
> > 
> > I've googled this problem but have found little help except that it
> > shouldn't happen and it should be reported.
> > 
> > I'm running FreeBSD 5.4 stable.  I'm temped to start over from scratch
> > but would hate to lose everythin on ad0 without first transferring it to
> > ad3.  I've tried to mount ad3 and ad3c (the only references to ad3
> > in /dev) using:
> > mount /dev/ad3 /mnt/bigdrive but get an error:
> > mount: /dev/ad3 on /mnt/bigdrive: incorrect super block
> > 
> > So I'm pretty lost.  Any help would be greatly appreciated.  I've spent
> > 4-5 hrs googling for solutions but nothing seems to work.
> It sure *sounds* like you accidentally did your install to the old
> disk instead of the new one.  If that is the case, then your old data
> are indeed lost -- overwritten with the new install.
> Also, it sounds like you were following the advice for moving your
> whole system to the new disk, whereas the advice for *adding* the new
> disk to the old one would have been more appropriate.  That's the
> "disk formatting tutorial" article in the documentation collection.

More information about the freebsd-questions mailing list