Diagnosing reboot under load

Micah micahjon at ywave.com
Mon Nov 7 17:26:10 GMT 2005

Alex Zbyslaw wrote:
> Bill Moran wrote:
>> Bill Moran <wmoran at potentialtech.com> wrote:
>>> Micah <micahjon at ywave.com> wrote:
>>>> I'm running the i386 version of FreeBSD with 1gb ram.  Didn't think 
>>>> to check this before, but I'm getting ~112-113 volts into the PSU 
>>>> from the surge strip.  I'm probably going to get a new PSU today.  
>>>> The parts store has a couple of 400 watters in the $50 range (a 
>>>> fortron and a thermaltake).
>>> Cheap power supplies are a near guarantee that your computer will be
>>> unstable.  Unfortunately, $cheap doesn't always == quality cheap.
>> I recommend the more recent one as a guage for what manufacturers you
>> can trust.  Frankly, if you're only spending $50 on a 400W, you're
>> probably getting a piece of junk - although Fortron has been rating
>> well in Tom's tests.
> A PSU actually capable of 350W *ought* to have done you fine, but many 
> cheap PSUs, as Bill says, just don't cut it.  I'd personally recommend a 
> Seasonic, which won't be cheap, but will be quiet and reliable if mine 
> is anything to go by.  Antec also seem to have a reasonable rep.
> There's a nice wattage claculator here: 
> http://www.jscustompcs.com/power_supply/Power_Supply_Calculator.php?
> --Alex

Thanks for the link.  I actually used that calculator when I pieced this 
machine together.

I'm really beginning to doubt it's the PSU.  Why?  I cannot get the 
output voltage to drop no matter what load I throw at it.  I plugged in 
four additional hard drives and ran a system stress test and still the 
voltages remained rock steady at the values I stated earlier.  I ran it 
for an hours with the high-low monitor on a Fluke multimeter.  The +5 
stayed near 5.1 with 5.08 as the bottom, and the +12 stayed near 11.89 
with 11.84 as the minimum.  I even had one of the "random segfaults" and 
the +12 voltage never dropped below 11.84.  I'm not sure how I can get 
the load any higher without using resistors which most certainly does 
not simulate the load I'm generating while compiling.

That leaves memory, CPU or mobo.  I ran memtest86+ and it reported no 
errors.  I'll run it again for an extended period of time while I'm at 
school to see if it reports anything.  That leaves CPU and mobo.  Anyone 
got any ideas how to test those?  The only system test I can run that 
does report an error is Lucifer 1.0 (on the ultimate boot cd).  The 
mprime test and cpuburn do not find any errors.


More information about the freebsd-questions mailing list