Odd boot problem

Joao Barros joao.barros at gmail.com
Sun Nov 6 15:12:00 GMT 2005

On 11/5/05, Joao Barros <joao.barros at gmail.com> wrote:
> Hi,
> I needed to add an IDE disk to an already running SCSI booting machine
> for testing.
> Recently upgraded to 6.0 :) with the IDE disk connected to the
> machine, although not mounted.
> After a make kernel the machine boots fine but only if I have the IDE
> disk connected.
> Booting from the scsi disk I can clearly see it's trying to find the
> load from the ide disk.
> I tried 'atacontrol detach ata0' and reinstalling the kernel and tried
> a bsdlabel -B da0 but I still get the error, boot message follows:
> F1 FreeBSD
> Default: F1
> Invalid partition
> Invalid partition
> No /boot/loader
> FreeBSD/i386 boot
> Default: 0:ad(0,a)/boot/kernel/kernel
> boot:
> I tried 0:da(0,a)/boot/kernel/kernel but still no go.
> How can I fix this?
> --
> Joao Barros

One more odd thing I noticed:
With ad0 attached like as before this problem occurred I correctly see
this at the loader:
F1 FreeBSD
F5 Drive 1

Drive 1 is a raid array on another controller.

With ad0 disconnected and da0 being the boot drive I only see:
F1 FreeBSD

Considering that doing a make work && kernel with a ad0(which I guess
BIOS will see as the new drive 0) attached after the initial system
installation on da0 rendered booting from
da0 unusable, I think something very wrong must be happening.
The disk to consider writing any new boot information should be the
one where / lives in, not disk 0 reported by the BIOS. Well, that's my
view of it anyway...

I'm really unable to restore booting capabilities to da0 so any hints
are highly appreciated.

Joao Barros

More information about the freebsd-questions mailing list