FW: Cron Job will not run.

Brandon Hinesley brandonh at hotandcold.biz
Thu Nov 3 21:00:55 GMT 2005

I added /usr/local/bin to /etc/crontab
It's still not working.  It doesn't seem to run anything in the script at
all; rotations or rsync'n.

-----Original Message-----
From: Alex Zbyslaw [mailto:xfb52 at dial.pipex.com] 
Sent: Thursday, November 03, 2005 12:47 PM
To: Brandon Hinesley
Cc: freebsd-questions at freebsd.org
Subject: Re: Cron Job will not run.

Brandon Hinesley wrote:

>The script below works perfectly when I run it from a console, however,
>nothing at all seems to happen as evidenced by the backups not being
>rotated.  I don't know if this makes a difference, but the "Backup" folder
>is a file system on an external hard drive.  I am also using samba to share
>that folder as r/o.  
>Here's part of my /etc/crontab:
>rsync -av --delete $files/$docs $dbkups/0/
This is a FAQ, though I don't know if it's in the FAQ :-)

 From the command line /usr/local/bin (where rsync lives) is in your 
path.  From Cron it is not.  Either add it to the crontab or set PATH in 
your script.  The latter is recommended since the script works whatever 
the running user has their path set to.  There may be some other path 
problem I've missed, but this ones sticks out.


More information about the freebsd-questions mailing list