make builworld fails owing to libstdc++ problems

Denny White dennyboy at
Mon Jun 27 21:40:07 GMT 2005

Hash: SHA1

On Mon, 27 Jun 2005, Giorgos Keramidas wrote:

> On 2005-06-27 22:10, Vittorio De Martino <vdm.fbsd at> wrote:
>> Alle 07:26, luned?? 27 giugno 2005, Vasil Dimov ha scritto:
>>> On Sun, Jun 26, 2005 at 09:33:19PM +0200, Vittorio De Martino wrote:
>>>> uname -a
>>>> FreeBSD fbsd.grtn 5.4-RELEASE-p2 FreeBSD 5.4-RELEASE-p2 #0: Sat Jun 25
>>>> 17:40:47 CEST 2005
>>>> I have the following in ....
>>>> in make.conf
>>>> CPUTYPE=p4
>>>> CFLAGS= -O2 -pipe -funroll-loops
>>>> COPTFLAGS= -O2 -pipe -funroll-loops
>> I tried but the same error stil pops up. What else should I do?
>> Vittorio
> Start by removing all the fancy options from make.conf and starting
> *WITHOUT* any make.conf file in /etc.
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

I'm not a programmer, but I have read where the funroll-loops
can produce unstable code. And, I can attest to the fact that
my system complained about the other flags you've got there &
which I also tried to use, except for the cpu type. I had to
stop, do some house cleaning, delete the stuff out of make.conf,
& start over. Then everything went smoothly. And, as I said, I'm
not a programmer, but I sat & watched the build going on after
fixing make.conf, & I saw it using the same values, except for
funroll-loops, that I had had in make.conf. Go figure! I know
someone on this list can probably clear that up, as to why.
Meantime, I'd do what the other answer to your post said to do
& remove that stuff from make.conf & start over. If you still
run into some problems, maybe it'd be because of the stuff left
behind from when you tried to build before. Then you might want
to clean up your /usr/src & /usr/obj's too. That is,

cd /usr/src
make clean
cd ../obj
chflags -R noschg *
rm -rf *

which will clean up from what you've previously done. Then again,
you might want to wait until some more folks read this post and
see if you get any more input. I'm just telling you what's worked
for me in the past.

Denny White

Version: GnuPG v1.4.1 (FreeBSD)


More information about the freebsd-questions mailing list